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1. Introduction 
This Release Content Description provides information about new or changed functionality that will be 
available in Outpost Packet Message Manager Release 3.2.  This information is organized under the 
following sections: 
 New Features:  A new capability that did not exist in any prior version of Outpost in any form. 
 Enhancements:  A change to an existing feature that further improves the performance or usability of 

the application.  Enhancements include minor or internal changes (that may not be evident to the user, 
but contribute to improved supportability increased stability, or application performance). 

 Defect fixes:  A change that resolves a reported problem. 

2. New Features 

2.1. ER#1026: Ics213mm and Keep Local  
The Ics213mm program and associated functionality allows an Outpost user or local user to create a 
standard ICS213 message and have it sent to a remote location where it can be downloaded and presented 
in a familiar ICS213 message format.   
While this capability has worked well for many users, the question was poised: how do I use Ics213mm to 
send a message to some other user within my EOC or ICP (on the same LAN)?  The ability to create typed 
messages and share them within an EOC is very appealing and offers some level of automation for a 
responding organization. 
This change allows an Ics213mm message to be kept local and routed to a different user on the same LAN.  
In this case, the Outpost program acts as the server for these local users.   
What Changes: 
1. Allows Ics213mm to create and send a message to another Ics213mm station on the LAN.   
2. Adds an Outpost message form option to override the Ics213 routing and reroute back without 

invoking a Send/Receive session. 
3. Adds an Outpost message option to create an Ics213mm message from a received packet message.  

This now lets regularly received packet messages be presented to the EOC/ICP staff in a format 
familiar to them. 

4. Adds an option to Ics213mm Browsing functionality to open on the first or last message in the list. 
5. Adds an option to Ics213mm to make the contents of the header fields the default fields. 
6. Ensure Keep Local messages are logged in Ics309. 
7. Fixes Outpost logic to update the Outpost record only after the message was sent to back to Ics213mm. 
Migration:  No program migration is required. 
Documentation:  Updates to the Ics213mm Users Guide will be made to elaborate on this new capability. 
Related:  ER #1307, #1308, #1321, #1328, #1329, #1332 
 

2.2. ER#1232: Implement Add-ons 
The Ics213 Message Maker, NTS Message Maker, and Santa Clara County’s PacFORMS are essentially 
alternate ways to create messages to be sent by Outpost.  In almost all cases, some element of Outpost hard-
coding was required to make these add-ons work.   
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Users have requested the ability to create and send their own message formats as well, such as local CERT 
status reporting and a 9-1-1 message form to name a few.  This release introduces a standard approach for 
individuals to add on their own message creation programs.  You will still need to write your own message 
formatter, but the method to hand it off to Outpost will now be well defined. 
What Changes: 
1. Creates a straight-forward add-on / Outpost interface that keeps the interaction simple. 
2. Adds detection and processing of a new Launch.local file that is not overwritten when installing a new 

version of Outpost. 
3. Adds a new message status (“submitted”) to differentiate an Outpost created message from an add-on 

sourced message. 
Migration:  No program migration is required. 
Documentation:  an add-on application note will be created to describe this new capability. 
Related:  ER #1215, #1339, #1344 
 

3. Enhancements 
ER #1110: TLD Addressing.  Previously, Outpost attempted to be “helpful” by ensuring that any 
email addresses entered was valid.  This was fine when the Top Level Domains were .com, .edu, .net, 
.org, etc.  This no longer works.  With the explosion of top level domains (now ~678 TLDs in the 
IANA database), TLD checking is removed from Outpost so that any TLD (like .beer, .tv, etc.) is 
handled correctly.   
ER# 1122:  Profiles.  This change now lets you control how changes to specific Outpost settings are 
managed (does not cover changes made to BBS, TNC, User UAC, or Address book entries).  You can 
now set up Outpost to either (i) always save profile settings, or (ii) prompt to save, or (iii) never save 
on changing profiles or existing Outpost.  This may be useful if you share an Outpost PC with multiple 
users and want to ensure changes for specific settings are consciously managed. 
ER# 1146:  Install.  Add Outpost.profile name to the existing Outpost.profile to preserve the Call 
Sign, BBS, and TNC. 
ER# 1160: Custom Retrieval.  This change adds a new message retrieval option on the Setup > BBS > 
Retrieving tab.  Along with the existing retrieve options, you can now add enter your own BBS retrieve 
commands.  This may be most useful for JNOS users where the concept of Areas exists.  This option 
will be unchecked on installation. 
ER #1161, 1174:  BBS Setup and Retrieving.  This change moves the Tools > Send/Receive > 
Retrieving Tab to Setup>BBS/ Retrieving Tab.  Retrieve settings are really BBS-specific.  Prior to this 
change, every time you changed BBSs, you probably went to this Send/Receive tab to change what 
you were retrieving.  This situation is now resolved.  
Migration:  when you first run Outpost after installing v3.2, you should double-check that your 
retrieve options are properly set.  By default, only the  Retrieve Private option will be initially 
checked for all BBS.  No migration of retrieve options will be performed. 
ER# 1314: Send Message Filtering.  Today, Outpost checks to make sure that the BBS listed on the 
messages matches the BBS to which it is connected.  The problem this presented was when user “A” 
created a message for this BBS, and User “B” created a different message for the same BBS.  Then, 
when connected to the BBS, both messages would be associated to which user ID was selected at BBS 
connect time.  This change now adds a check for the user name along with the BBS name when 
determining which messages are sent for the selected user/BBS combination.  This also means that, if 
you are User “A” and someone else created messages under their own ID, their messages will not get 
sent until either (i) the Station ID is changed to them, or (ii) the FROM: field is changed to your ID. 
ER# 1320:  Winlink SMTP: prefix.  This was another attempt at Outpost helping the user.  Because 
Winlink required an SMTP: prefix to email addressed messages, Outpost originally attempted to keep 
the listing clean by removing and reinserting the SMTP: prefix for Winlink destined email addresses.  
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This worked find until a message was passed through a BPQ node in route to Winlink.  In short, the 
SMTP: prefix will no longer be removed by Outpost. 
ER# 1326: Additional folders.  At some point, Outpost will get real folder functionality.  Until then, 5 
additional folders have been added for your general use. 
Migration:  The default folder names are “Folder 1” through “Folder 5”.  You can change the names 
from the Tools > General Settings form. 
ER# 1327:  Logging.  This change expands any TO: Field address book entries found in a message 
when writing to the Transaction Log.  This will be a good troubleshooting aid when trying to work out 
addressing problems. 
ER# 1334: StringLib.  This is an internal change to further optimize the StringLib use by Outpost. 
ER# 1340:  Message Counts.  This enhancement changes the message count format in the lower left 
corner of the Outpost main form to now show Items: ### (number of messages in this folder) and 
Unread: ### (number of unread messages in this folder). 
ER# 1350:  PacFORMS.  On a received !PACF! Message, disable REPLY and FORWARD on the 
message form. 
ER# 1355:  Message Handling.  Enhance message header tab management, support cntl-tabbing to 
move back one field. 
ER# 1361:  BBS Setup.  Reconfigure KA-Node Path controls to be more intuitive. 
ER# 1362:  Station ID Setup.  Rewrite Station ID form.  Deliver utility to convert  v3.1 user ID data 
structures to 3.2. 
ER# 1363:  Logging.  Change Srnote.log file directory to the logs directory. 
ER# 1364:  Install.  Rename OpupdateXX and IdupdXX programs to avoid triggering the Windows 
Installer Detection Technology compatibility heuristic. 
 

4. Corrections/Defects 
ER# 884: Msg Handling, Drag and Drop.  Fixes ER #525 so that the drag-n-drop of one or more 
messages from one folder to another now uses the LEFT mouse button.  This is consistent with 
standard Windows drag and drop behavior. 
ER# 1072:  Reply-to-All.  Corrected Outpost behavior when replying to a message.  Reply-to-all will 
only go to the original sender plus the others that were copied on the original message, and not 
yourself. 
ER# 1078:  Leading/Trailing blanks.  Corrected the situation to leave any user-inserted leading or 
trailing blank lines in the message. 
ER# 1134:  Profile Switching.  Resolved problem where switching Profiles too quickly resulted in 
inconsistent results. 
ER# 1282:  Ics213, String Error.   Resolves a string parsing issue when the word “ROUTE” was 
actually part of the text and trapped as a message TAG.   
ER# 1290:  Ics213, String Error.  Resolves a string parsing issue when a !PAC! tag was actually part 
of the text in an Ics213mm message and triggered a PacFORMS PacRead event. 
ER# 1315: Ics213mm does not always close the first time.  This change is a first pass at attempting 
to resolve the situation when the user clicks to close Ics213mm when it is in the middle of a 
send/receive session.  While not perfect, it is a start. 
ER# 1316:  Error 91.  Corrected the situation where, if the user right-clicked on the main Outpost 
form when no messages were listed, the system generated an Error 91. 
ER# 1324:  Profiles dropdown.  The Profile Drop-down list on the main form did not size correctly 
as the form width was reduced.  A change was made to ensure the drop-down control resized and 
always was presented correctly. 
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ER# 1325:  Script & File Browsing.  In Script Settings, fixes the default view with browsing was set 
to Wave (.wav) files when it should have been set to .txt files.   
ER# 1333:  Ics309.  Corrected a problem where the date passed to Ics213mm was loaded with a 
comma instead of a period. 
ER# 1336: Installer.  Fixed .ini file FilePON defaults to check for gDATA_PATH and replace it with 
the real one. 
ER# 1337:  JNOS CC: handling.  Resolved incorrect handling of CC address on incoming JNOS 
messages. 
ER# 1338:  BBS Setup.  Resolved situation where the BBS Friendlu name persisted even after a BBS 
delete was executed. 
ER# 1347:  Ics309 Error.  Resolved problem where the Ics213mm program hung on loading a blank 
record. 
ER# 1348.  Ipserial Error.  Resolved problem when the user selected File > Open file, and then 
pressed Cancel.   
ER# 1353.  Msg Folders.  Resolved problem with changing folders; shows top msg highlighted, but 
not really selected. 
ER# 1356.  Send/Receive.  Resolved problem with Winlink Msg “From” fields not captured correctly. 
ER# 1358.  Msg Handling.  Resolved problem with a message that only has one space character 
shows as blank length. 
ER# 1359.  Msg Handling, Drag and Drop.  Resolved problem with Edit > Move; does not behave 
like the other drag and drop processes. 
ER# 1360.  Msg Handling.  Resolved problem when the DEL key was not picked up by the Del Menu 
Key association.  Add test on LV KeyDown to detect a key press. 
ER# 1365.  Installer.  Resolved problem when installing on W10 from scratch, not all of the data 
subdirectories get created at run time (when the check is made and the directories are created) resulting 
in various file errors. 
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